What Operating System and Device do I need?

Ubersense requires iOS 7 and can be used on the iPad, iPad Mini, iPhone and iPod Touch

Feedback and Knowledge Base